Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Raft
Level 7

HBOMax Network Error on a New Roku Ultra 4800R

After installing a brand new 4800X Roku Ultra with software version 10.5.0 build 4167-C2, all the channels are working fine (NETFLIX, PRIME, AppleTV) except HBOMax. I see the HBO splash screen, then the 3 dots, then I receive a "NETWORK ERROR Unable to communicate with service" after about 10 seconds. I have "excellent" wifi signal strength according to the 4800X, with a 184 MB per second download speed. 

I also have a 4660X2 Roku Ultra in another room and it works fine on HBOMax. I swapped the two of them, and the new 4800X still gives the same error in the other room with a different TV. I tried removing the channel and re adding it, rebooting etc. The problem clearly is with the ROKU 4800X.  Please help, Thanks.

 

0 Kudos
12 REPLIES 12\
renojim
Community Streaming Expert

Re: HBOMax Network Error on a New Roku Ultra 4800R

When you removed the channel and readded it, did you reboot/restart between removing it and adding it?  If not, try it again ensuring you restart your Roku after you remove the channel and before adding it again.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
Democracizer
Level 7

Re: HBOMax Network Error on a New Roku Ultra 4800R

I am having the same exact issue and I got the ultra. I tried deleting app and then restarting but no luck. Tried deleting cache. Every other streaming app I have works. My internet is good. I logged everyone out of hbo and still nothing. Need to call customer service I guess

0 Kudos
Raft
Level 7

Re: HBOMax Network Error on a New Roku Ultra 4800R

It's got to be a software firmware problem between the new Ultra and HBO Max. Sad when an older model of the Ultra works and the newer box does not. I tried removing the channel and perform a cold boot then re adding it. Still gives me the same error. I have no problems with any other channels including Apple TV+, Netflix, and Prime. Hope ROKU engineers give us a fix soon or I will sell it on Ebay and buy an NVidea Shield Pro.

0 Kudos
azerik
Level 7

Re: HBOMax Network Error on a New Roku Ultra 4800R

My older Ultra has been having this issue for a month or so. I've finally given up on my Roku. My PS5 rips right into a show none of this nonsense.

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: HBOMax Network Error on a New Roku Ultra 4800R

@azerik

Thanks for the post.

Does the issue only occur on a specific channel or across other channels installed on your Roku device?
If you haven't tried yet, you can remove the affected channel then re-install it. To ensure the process is successful, make sure to restart your device before adding the channel back in. We would recommend doing this from the Settings menu by navigating to Settings > System > System restart > Restart.
For detailed instructions, refer to this Support link: How do I resolve channel playback issues?
 

All the best,

Irene

Danny R.
Roku Forum Moderator
0 Kudos
azerik
Level 7

Re: HBOMax Network Error on a New Roku Ultra 4800R

It has happend once or twice on the Apple TV channel(channel froze, returned to home screen). But the HBO this is now constant. Even reboots, resets (I even went into the hidden menu and reinstalled the last OS patch, which resolved the HBO thing for about 5 minutes, then after a couple closing and reopening the channel it stopped loading even the full landing page.).

Now interestingly I don't have the HBO Max channel logo. I have the block, and the block title of HBO Max, and I can launch the channel but the home screen doesn't have a logo. Deleted and reinstalled, with reboots and reboots after reinstalling the channel. No luck.

I took a look at the antenna info and it's not bad. The glitching does stay around 0 to 4, but sometimes shows 150+ for a second then back to 4 to 0. I was going to factory reset it but I think that's overkill. I do have an SD card in the player but it's only using 500 megs of that card. Not sure if Max is stored on the card or not, but it's an old 2gb sd card.

It feels to me like it's corruption in the profile or some pre-loader that they're using because only 1 or 2 requests ever go out when launching and it doesn't work. No real retries. Watching the Roku on the network the signal etc all sits stable. 

I've deleted and reinstalled it 5 times I think today. Now it's basically not functioning. But my PS5 zips right in plays instantly. The Roku hickups. I did notice with Apple TV+ it's now taking a few seconds to start to play 4k content and there's a lot of banding. The Ultra's connection speed is 173Mbps/6Mbps Down/Up. And it's connected AC to a Unifi Lite Wifi 6 AP that's maybe 20 feet away 44% signal though.

0 Kudos
JJ28
Level 7

Re: HBOMax Network Error on a New Roku Ultra 4800R

I have the same issue and I'm using an old Roku 3. So I doubt the problem has to do with the 4800R - it's probably an internal Roku software issue.

0 Kudos
azerik
Level 7

Re: HBOMax Network Error on a New Roku Ultra 4800R

I think I found it. 

WPA3 and it's optional protected management frames appear to not play well with the 4660 Ultra. I put the unit on a 2.4g SSID with wpa2 and no PMF and it fires up every time. A touch slower than when AC was working properly. I think this might be something for the Roku team to look into. I have a few SSID's but only 1 that is dedicated AC/AX with WP2/3 mixed mode with Optional frames. Perhaps the Wifi6 possibility is just angering the unit. Either way it doesn't connect faster than 175Mbps down so having it connected at 1300MBPs doesn't do anything.

0 Kudos
RicCrouch
Level 7

Re: HBOMax Network Error on a New Roku Ultra 4800R

Azeris May have found one thing that causes it, but I have the same problem on wired Roku Ultras, so it’s more than a WPA issue.

 

Ric

0 Kudos