Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Toddwrtr
Level 8

Re: Disney+ not displaying UltraHD & HDR even though I have proper Roku device

Jump to solution

Except the Amazon Firestick 4K does not support Dolby Atmos on Disney+...

0 Kudos
Highlighted
MikeG
Level 8

Disney+ not displaying UltraHD & HDR even though I have proper Roku device

Jump to solution

Hi, I'm also having the same issue with getting 4K on Disney+.  I changed my Roku to 4K HDR 60Hz and it seemed to fix the problem (the Disney 4K movies show up as being in 4K).  However, now the picture and sound flickers every 5 seconds or so (makes it unwatchable).  I tested this setting on other channels (Netflix, Amazon, etc,) and the same thing happens.  When I change the setting to 4K HDR 30Hz, everything works fine, except that now the 4K movies on Disney show only in HD.  Why doesn't Disney+ detect 4K HDR at 30Hz?

I have a 4K Roku and I just did the firmware update.  My display options include 720, 1080, 4K 30Hz, 4K 60Hz, 4K HDR 30Hz, and 4K HDR 60Hz.

I've got a 2019 Samsung Q60R 82" TV that is capable of 4K HDR 60Hz.  All my cables are HDMI 2.0.  My amplifier is a 2019 Onkyo HT-R695 that I believe is rated for 4K HDR 60Hz.   I've scoured the manuals for the TV and amplifier with little success. 

So, any idea why I'm having trouble streaming 4K HDR 60Hz?  Any input would be welcome.

0 Kudos
Highlighted
atc98092
Level 17

Re: Disney+ not displaying UltraHD & HDR even though I have proper Roku device

Jump to solution

@MikeG wrote:

Hi, I'm also having the same issue with getting 4K on Disney+.  I changed my Roku to 4K HDR 60Hz and it seemed to fix the problem (the Disney 4K movies show up as being in 4K).  However, now the picture and sound flickers every 5 seconds or so (makes it unwatchable).  I tested this setting on other channels (Netflix, Amazon, etc,) and the same thing happens.  When I change the setting to 4K HDR 30Hz, everything works fine, except that now the 4K movies on Disney show only in HD.  Why doesn't Disney+ detect 4K HDR at 30Hz?

I have a 4K Roku and I just did the firmware update.  My display options include 720, 1080, 4K 30Hz, 4K 60Hz, 4K HDR 30Hz, and 4K HDR 60Hz.

I've got a 2019 Samsung Q60R 82" TV that is capable of 4K HDR 60Hz.  All my cables are HDMI 2.0.  My amplifier is a 2019 Onkyo HT-R695 that I believe is rated for 4K HDR 60Hz.   I've scoured the manuals for the TV and amplifier with little success. 

So, any idea why I'm having trouble streaming 4K HDR 60Hz?  Any input would be welcome.


Some online media providers require 60 Hz for 4K HDR. I believe Netflix is the same way. So you must be set to 4K/60 for Disney+.

On your Samsung TV, make sure UHD Color is enabled on your HDMI port that the Roku/Onkyo is connected to. Also make sure the Onkyo is not performing any video processing/upscaling. I don't know if it has any internal setting that might need to be enabled for full 4K/60 passthrough like my Yamaha AVRs does.

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Highlighted
MikeG
Level 8

Re: Disney+ not displaying UltraHD & HDR even though I have proper Roku device

Jump to solution

Update: My Samsung TV doesn't have a UHD Color option for the HDMI port I'm using (HDMI 1), but you can select the "Enhanced Feature", for any of the 4 ports (I selected it for HDMI 1).  Maybe I'll try to de-select it and see what happens.

I was finally able to run the Disney+ app directly from the TV.  It appeared to run fine in 4K HDR 60Hz.  So, this tells me that the problem is probably with the Onkyo amp and/or the Roku.  Also, I ran a cable test on the Samsung - it said that my HDMI cable was bad (the one that goes from the Onkyo to HDMI 1).  The cable is HDMI 2.0 and is only 6 months old.  I'll check the specs on it. 

I turned off the 4K upscaling on the Onkyo, but it didn't make a difference with the flickering issue. 

I'll give Onkyo a call.   Still searching...….

0 Kudos
Highlighted
atc98092
Level 17

Re: Disney+ not displaying UltraHD & HDR even though I have proper Roku device

Jump to solution

@MikeG wrote:

Update: My Samsung TV doesn't have a UHD Color option for the HDMI port I'm using (HDMI 1), but you can select the "Enhanced Feature", for any of the 4 ports (I selected it for HDMI 1).  Maybe I'll try to de-select it and see what happens.

I was finally able to run the Disney+ app directly from the TV.  It appeared to run fine in 4K HDR 60Hz.  So, this tells me that the problem is probably with the Onkyo amp and/or the Roku.  Also, I ran a cable test on the Samsung - it said that my HDMI cable was bad (the one that goes from the Onkyo to HDMI 1).  The cable is HDMI 2.0 and is only 6 months old.  I'll check the specs on it. 

I turned off the 4K upscaling on the Onkyo, but it didn't make a difference with the flickering issue. 

I'll give Onkyo a call.   Still searching...….


Both of my Samsung sets have a UHD Color setting for the HDMI ports, but on the newest one it's really difficult to find. I'm not at home so I can't offer help where it is.

If the Roku does 4K/60 fine connected directly to the TV but not through the Onkyo, then there's nothing wrong with the Roku. It's either the Onkyo or the cables. In my Yamaha AVRs, there's a hidden advanced menu (only available on power up with certain buttons held) that offers "Mode 1" and "Mode 2". Those a probably Yamaha specific names, but Mode 1 has to be enabled for 4K/60 HDR to passthrough. Perhaps Onkyo has something similar. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Highlighted
MikeG
Level 8

Re: Disney+ not displaying UltraHD & HDR even though I have proper Roku device

Jump to solution

Actually, I haven't tried connecting the Roku directly to the TV (bypassing the Onkyo).  That's my next step.  I don't have any spare HDMI 2.0 cables....

0 Kudos
Highlighted
MikeG
Level 8

Re: Disney+ not displaying UltraHD & HDR even though I have proper Roku device

Jump to solution

I checked the HDMI ports on the TV.  I have to select the Special Feature on HDMI 1 to get the 60HZ HDR signal to come thru, which I did.  I don't think the TV is causing the problem.

0 Kudos
Highlighted
atc98092
Level 17

Re: Disney+ not displaying UltraHD & HDR even though I have proper Roku device

Jump to solution

@MikeG wrote:

Actually, I haven't tried connecting the Roku directly to the TV (bypassing the Onkyo).  That's my next step.  I don't have any spare HDMI 2.0 cables....


No such thing as an HDMI 2.0 cable. What does exist are 18 Gbps speed cables, and that's what you need. Although for a test a short (3' or less) but slower speed cable might work for testing. Smiley Happy

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Highlighted
MikeG
Level 8

Re: Disney+ not displaying UltraHD & HDR even though I have proper Roku device

Jump to solution

I did a test by connecting the Roku to the TV directly using a regular HDMI cable.  The 4K HDR at 60 Hz worked perfectly.  So, it's not Roku and it's not the cables; it's the Onkyo receiver.  I called Onkyo Customer Service and they said to lower it to 30Hz,  Duh!  I know that .  So, basically, Onkyo is aware of the problem, but doesn't know how to fix it.  Very disappointed!  Anyone else out there have a similar issue?

0 Kudos
Highlighted
Toddwrtr
Level 8

Re: Disney+ not displaying UltraHD & HDR even though I have proper Roku device

Jump to solution

There should be a setting somewhere on the Onkyo to enable HDR pass through. On both Denon and Marantz receivers, it's under Video/4K Signal Format/Enhanced or Standard.

0 Kudos