Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Jashurt
Level 7

Disney+ not coming up when I click on Disney plus the screen just a button that says ok comes up.

when I click on it the screen loads but instead of going to the profiles it just goes to a screen with a button that says ok. I contacted Disney plus we cleared the cache we also robooted my internet. And it still doesn’t work. They finally said something is wrong with Roku so I went and bought a brand new Roku Express 4K + and it’s doing the same thing. Can anyone please help me. I’ve been paying for this for months and I can’t use it.

0 Kudos
7 REPLIES 7\
RokuKariza-D
Roku Employee
Roku Employee

Re: Disney+ not coming up when I click on Disney plus the screen just a button that says ok comes...

Hello @Jashurt

Thanks for bringing this to our attention.

Does the issue only occur on Disney+ or across other channels installed on your Roku device? Could you tell us when you started experiencing this problem? 

Moreover, try running a software update on your Roku then let us know if there's any difference after. Check out this link for instructions: How do I update the software on my Roku® streaming device?

Please keep us posted!

All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos
Jaym71
Level 7

Re: Disney+ not coming up when I click on Disney plus the screen just a button that says ok comes...

Same with mine. And it is only with Disney +. It acts like it’s going to load once you click the profile but then just gives the OK button. When you click that it goes back to the Roku main menu. 

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Disney+ not coming up when I click on Disney plus the screen just a button that says ok comes...

@Jaym71 

Thanks for the post.

Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more.

Does this clear up the issue you are seeing? Please keep us posted what you find out.

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Dasauls
Level 7

Re: Disney+ not coming up when I click on Disney plus the screen just a button that says ok comes...

I'm having the same issue. Just started. Already tried uninstalling and reinstalling. Tried testing the roku while it was uninstalled, still only says ok and closes. 

0 Kudos
Jaym71
Level 7

Re: Disney+ not coming up when I click on Disney plus the screen just a button that says ok comes...

I’ve done the same. Uninstalled, restarted the Roku, and reinstalled with the same results. If I keep attempting to get into Disney it’ll eventually let me in with out the Ok button. It’ll play for about 30 minutes or so then it’ll start playing the video out of sync with the voice. I’ll have exit Disney when that starts or the Roku will freeze up after a few min and require a manual restart. 

0 Kudos
Stevenic98282
Level 7

Re: Disney+ not coming up when I click on Disney plus the screen just a button that says ok comes...

I'm having the exact same issue. I've tried uninstalling the app, factory resetting the Roku, everything and I always just get an "ok" button. I even went into my Disney+ account and forced it to log out of my account but nothing helps. As the others have said, everything was working fine until a few weeks ago.

I saw that Disney+ was just updated so installed the new app but no luck.

0 Kudos
Stevenic98282
Level 7

Re: Disney+ not coming up when I click on Disney plus the screen just a button that says ok comes up

So I got mine to work after setting in chat with Disney+ for an hour. I ended up removing my micro SD card and then removing the app and reinstalling it. The support guy said he poked something related to my IP address but I'm pretty sure it was the SD card causing issues.

0 Kudos