Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 
Jmljr93
Level 8

Disney+ TCL TV- Subtitles Won’t Turn Off

Jump to solution
Hi all,
On my TCL 5 series tv, the Disney+ app works but for some reason, there are automatic subtitles on every show/movie. And there is no option to turn them off while watching the title. Also, lots of older titles like “Davy Crockett” have German subtitles. It’s quite hilarious, but frustrating that they cannot be adjusted on TCL Roku app. Anyone else experiencing this? Or know to how get TCL to fix the bug?
0 Kudos
1 Solution

Accepted Solutions
Discretion
Level 7

Re: Disney+ TCL TV- Subtitles Won’t Turn Off

Jump to solution
I found the answer. I have the same TCL. Go to the home screen and highlight the Disney Plus App, once highlighted push the * button on your remote. It will bring up a menu for the app. Select update, it will update your app and the subtitles should be off. That worked for me at least

View solution in original post

14 Replies
Tivoburkee
Level 14

Re: Disney+ TCL TV- Subtitles Won’t Turn Off

Jump to solution

While viewing a show press the asterisk *, from the left side a menu shows up, scroll down to captions and turn them off.

0 Kudos
Community Manager
Community Manager

Re: Disney+ TCL TV- Subtitles Won’t Turn Off

Jump to solution
Thanks for reaching out. Try pressing the * button during playback and access the option menu to turn closed captions off. You may also need to log into your Disney+ account online, and check your settings to see if this is enabled anywhere. These settings may carry over from your account into the channel/app automatically.

If you need more help, please contact Disney+ support. Let us know what you discover!

Thanks,
Tanner
Tanner D.
Roku Community Manager
0 Kudos
Jmljr93
Level 8

Re: Disney+ TCL TV- Subtitles Won’t Turn Off

Jump to solution
Hi,
Yeah it isn’t the TV CC system. When I click the *, Closed Captioning is already turned off as per usual. The shows and movies themselves have the subtitles already attached during playback and no way to turn them off. Only happening on my TCL Roku tv. Does not happen on my LG C7 tv and that interface has an option in playback for subtitle preference.
I’ll contact Disney+, thanks!
CtheK
Level 7

Captions Stay on Screen - Even When Clicked Off

Jump to solution

Hi I have a problem - my Captions stay on with every movie in Disney+ and with the Roku App despite me turning it off on the individual apps and on the system as a whole. How do I fix? It is turned off on the home screen, and turned off in App - yet it still shows. Does anyone have an answer to this? 

0 Kudos
Discretion
Level 7

Re: Disney+ TCL TV- Subtitles Won’t Turn Off

Jump to solution
I found the answer. I have the same TCL. Go to the home screen and highlight the Disney Plus App, once highlighted push the * button on your remote. It will bring up a menu for the app. Select update, it will update your app and the subtitles should be off. That worked for me at least

View solution in original post

BRDodd
Level 7

Re: Disney+ TCL TV- Subtitles Won’t Turn Off

Jump to solution
This completely fixed my issues. Update or Check for updates.. Nailed it!!!
0 Kudos
caleb8462
Level 7

Re: Disney+ TCL TV- Subtitles Won’t Turn Off

Jump to solution
THANKS!!
0 Kudos
Rebelkitty
Level 7

Re: Disney+ TCL TV- Subtitles Won’t Turn Off

Jump to solution
Thanks! This was driving us nuts!
0 Kudos
Dizzney
Level 7

Re: Disney+ TCL TV- Subtitles Won’t Turn Off

Jump to solution

I am having similar issues. I updated the app and no change. I've been having a Star Wars marathon and for 2 films it showed the subtitles all the way through. Can't remember which one was first but now it was doing it on Empire Strikes Back. The others have been fine. I tried to go in and switch to Off, During Replay and even On, but no change. Really frustrating. I ended up exiting all the way out and going back in and now they are gone but something is glitchy somewhere.

0 Kudos