Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Devices stopped streaming Netflix suddenly

I'm experiencing a strange issue. All of the Netflix apps on devices in our home suddenly stopped streaming Netflix. This happened with a standalone Roku device, a Roku TV, and our XBox One. The XBox complains about errors tvq-st-103, tvq-st-106, and tvq-st-143. Yet we can stream Netflix from all of the computers in the household, using the same network, even on the same XBox when using the browser (as opposed to the app). Two of the devices have one Netflix account, and the third device (the Roku TV) has a different Netflix account. I've tried restarting the devices, logging out and logging back in the app on the devices, removing the Netflix app and reinstalling, but nothing changes the behavior. When starting the Netflix app it just hangs and doesn't get to the Netflix menu.

I welcome any suggestions!

 

 

0 Kudos
2 Replies
Highlighted
Level 7

Re: Devices stopped streaming Netflix suddenly

Same think happened to me over the weekend. I have 3 rokus and 2 of them stopped all of a sudden. I have contacted Netflix 4 times and they claim it's an ISP issue, which is not true. I hot spotted off my phone and have the same issue. I have an XBox One but don't have the Netflix app on there to confirm that one. I do know all of my phones and PCs can stream Netflix just fine. Here's what didn't work:

Uninstall and reinstall Netflix

Switch ISP/Networks

Factory Reset of Roku

Resetting Router and/or modem

Unplugging Roku for more than a minute to reset it

 

Here is what I just tried and it worked, sort of:

I did a factory reset so I could use another Roku account. I activated the Roku with a family member's account and guess what? Netflix actually started up and prompted me for my username and password. I am still not sure if that means it's a Roku account issue, or a pre-programmed Netflix issue. When I did a factory reset the first time, Netflix would not prompt for a user name, it just froze at the starting screen.

Does anyone know if there is a way to un-link the Netflix channel from a Roku account? 

I am not sure if removing devices from my Roku account will work, but I will try that next. 

**Update**

Un-linking all devices from my Roku account did not work. 

 

0 Kudos
Highlighted
Level 7

Re: Devices stopped streaming Netflix suddenly

Mine also has started this same thing but I just have to delete Netflix and add channel again and it works fine. Every day when I open Roku and try to start Netflix it does the same thing.
0 Kudos