Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Crave Account

When first logging into my crave account through my Roku smart tv, we used our friend crave account because he was subscribed to watch movies and we were not. Our friend has now cancelled his account so my boyfriend and I created our own and started subscribing so we logged in. But for some reason every time we go to crave it still automatically logs us into our friends account and we have to manually log out and log back in with our account. But this happens every time. We have tried accessing through service provider and through crave and nothing seems to work! What can we do to fix this. 

Tags (1)
Roku Employee
Roku Employee

Re: Crave Account


Thanks for the post.

Have you tried removing the Crave channel, restarting your Roku device, then adding the channel back again to see if that resolves your issue?

As a last resort, we would recommend removing the channel, trying to perform a factory reset on your device, then adding the channel back again. For more information about how to perform a factory reset, visit our Support page here: How do I factory reset my Roku® streaming device?

Please keep us posted.


Danny R.
Roku Forum Moderator
0 Kudos
Level 7

Re: Crave Account

I have the exact same problem and the Crave app will not allow us to delete it and then add it again. This is so frustrating to have to sign out and then sign in each time. Not to mention not being able to save your email or password and just hitting sign in. 

0 Kudos
Level 7

Crave Account changes not working

I have the same problem. Even deleted Crave, unplugged Roku, then plugged back in and reloaded Crave. Still has my old Crave subscription in the memory some place. I can't do a factory reset as my remote crapped out and all I have is my cell phone app remote. Most frustrating!

0 Kudos