Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Shrug_emoji_3
Level 8

Channels won’t connect despite strong connection

Jump to solution

Last night my internet provider (xfinity) did routine maintenance so everything went down. Today, the internet is back up, everything is connecting, and when I check my connection through roku it says it is strong and I’m getting all green checks. HOWEVER, anytime I click on ANY channel, it says I’m not connected. I have restarted my router and my roku both several times to no avail. My phone and laptop are working great on the WiFi. This roku has been on this network for 4+ years. Did it die? Everything seems to be working and connecting great, but the channels just aren’t on the same page. I’ve even tried deleting and reinstalling the channels. HELP! 

1 Solution

Accepted Solutions
Shrug_emoji_3
Level 8

Re: Channels won’t connect despite strong connection

Jump to solution

Couldn’t get anything to work so o did a complete system reset. Going through and putting in all these passwords is annoying but it seemed to fix the issue

View solution in original post

0 Kudos
16 REPLIES 16\
StreamerUser
Level 20

Re: Channels won’t connect despite strong connection

Jump to solution

Try enabling/adjusting your 2.4Ghz SSID mode setting to "B/G/N" (with the Xfinity app or via the configuration pages of your modem/router/gateway).

0 Kudos
Shrug_emoji_3
Level 8

Re: Channels won’t connect despite strong connection

Jump to solution

Couldn’t get anything to work so o did a complete system reset. Going through and putting in all these passwords is annoying but it seemed to fix the issue

View solution in original post

0 Kudos
JoshJace
Level 8

Re: Channels won’t connect despite strong connection

Jump to solution

Having same problem but only with YouTube and YouTube TV channels. Says can’t update to no connection. All other channels load work fine. Weird! HELP!

0 Kudos
StreamerUser
Level 20

Re: Channels won’t connect despite strong connection

Jump to solution

@JoshJace 

You didnt mention your Roku model # and firmware version: Settings/System/About

Known solutions/workarounds for apps not loading/closing to Home:

1) Check for updates: Settings/System/System update/Check now - try again

2) Restart Roku: Settings/System/System restart/Restart - try again

3) Change your Theme to the Roku Default: Settings/Theme/Restore default theme - try again

4) Change your Screensaver to a Roku clock: Settings/Theme/Screensavers - try again

5) Remove SD card (if installed) - try again

6) Remove app, RESTART ROKU: Settings/System/System restart/Restart, Add app - try again

7) Network connection reset: Settings/System/Advanced system settings/Network connection reset - try again

8) Completely unplug power from Roku for 10-15 minutes - try again

9) Factory reset: Settings/System/Advanced system settings/Factory reset <--- last resort

NOTE for #6: Do not remove the YouTube TV app - you will not get the app back until the end of the dispute

0 Kudos
jane2
Level 7

Re: Channels won’t connect despite strong connection

Jump to solution

I am having the same problem but only on 1 of 2 TVs using Roku sticks.  One TV is perfectly fine (including YouTube TV) but the other will not load several channels including YouTube and Apple TV.  I eventually got the Discovery+ to reload but not the others.  Again, it's only on one TV.  The network, wireless, and internet connection all come back as "excellent" with green check marks.  The error suggests that I "check my network" because Roku cannot "reload the channel from the network".  I've rebooked, removed and re-added channels, and check for all updates.  3 hours later...no change.  It's frustrating.  Any thoughts?  I've gone through the checklist provided by another user as well. Thanks.

0 Kudos
Shrug_emoji_3
Level 8

Re: Channels won’t connect despite strong connection

Jump to solution

I had to do a complete system reset back to factory settings to get mine to work. Seems to be okay now. Did that through the roku settings menu but there may be a tiny hidden button on your physical device. Good luck! 


@jane2 wrote:

I am having the same problem but only on 1 of 2 TVs using Roku sticks.  One TV is perfectly fine (including YouTube TV) but the other will not load several channels including YouTube and Apple TV.  I eventually got the Discovery+ to reload but not the others.  Again, it's only on one TV.  The network, wireless, and internet connection all come back as "excellent" with green check marks.  The error suggests that I "check my network" because Roku cannot "reload the channel from the network".  I've rebooked, removed and re-added channels, and check for all updates.  3 hours later...no change.  It's frustrating.  Any thoughts?  I've gone through the checklist provided by another user as well. Thanks.


 

0 Kudos
Bella21889
Level 8

Re: Channels won’t connect despite strong connection

Jump to solution

Did this fox your Hulu app? I ask because I got all of my channels to work again except Hulu peacock and pluto

0 Kudos
Brebrown20
Level 7

Re: Channels won’t connect despite strong connection

Jump to solution

I only have one TV that has that issue as well.  It cannot  be reinstalled from network.  I have restarted everything.  I have checked network.  Nothing seems to work. Would I need to just get a new Roku?

0 Kudos
borzoilady
Level 7

Re: Channels won’t connect despite strong connection

Jump to solution

My error message was a bit different saying I had to remove channels as there was no space, however even after removing three or four channels it still wouldn’t work so I checked my other TVs which were working fine with the same amount of channels or more so I swapped my Roku device and everything was fine so as it turns out it was the actual device which was not that old that was messing up the other TV. 

0 Kudos