Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Heyitsrick
Level 11

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Worked immediately for my Roku Premiere + after disabling auto-previews from my web browser. 

0 Kudos
Highlighted

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Same here with the Premier+ ... but can’t get them to stop on Stick+ or Ultra. 

0 Kudos
Highlighted
jkblack
Level 7

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Also cannot disable autoplay on my Stick+.  I've tried creating new Netflix profiles with autoplay disables, switching profiles, factory resetting the Stick+, forcing an update, unplugging it and reinstalling.  Nothing works.

0 Kudos
Highlighted
Ravenpen
Level 7

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Having the same issue with both Streaming Stick and Streaming Stick+. 

I've tried all of the solutions mentioned and nothing works.

0 Kudos
Highlighted
Unix61619
Level 7

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

This is clearly an issue unique to Stick owners. Netflix needs to update the channel so the previews can be turned off with Roku sticks. I’ve cancelled my Netflix service over this, and I suggest others do as well. That’s the only way they’ll notice, or care. When you cancel, be sure to give the reason as: “Couldn’t disable auto-preview on Roku stick”

If you try contacting Netflix support, let them now there is an issue with the sticks not being able to stop auto-previews. Don’t let Netflix tell you it’s a Roku issue, insist it is a Netflix channel issue, and you want it resolved. Try to get to a higher level support if possible. The more people that do this, the better.

I would also contact Roku and let them know you are upset that the device you bought is not entirely compatible with Netflix. As long as it is not an older Roku device that Netflix no longer supports, you should expect full compatibility... I purchased a Roku Stick+ just last month. If I cared about having Netflix, I’d be PISSED!!! I’d probably sell the stick and try something else like a Firestick. Roku obviously wants their devices to work with Netflix, and have an interest in getting Netflix to fix the issue.

My service is good until the end of the month. If Netflix makes the fix, I ‘might’ renew, but with HULU+, I really don’t miss it...

If they won’t fix the issue, speak with your wallets, and dump them!!!

0 Kudos
Highlighted
jkblack
Level 7

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

I noticed today that disabling autoplay not only doesn't work in my Stick+, it also does not work in my Windows 10 Netflix app which presumably was written by Netflix.

It does look like Netflix is aware of the problem.  The don't specifically mention Roku devices, but they seem to know that disabling autoplay doesn't work on some devices.  See: this link to Netflix help and expand the "All Other Devices" item.

 

0 Kudos
Highlighted
Unix61619
Level 7

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Jkblack,

Good find.

Disabling auto-previews works on all my Apple devices, just not my Roku Stick+.

i would encourage anyone that MUST have Netflix to follow that link and contact Netflix support about it. If they tell you to call Roku, tell them you want to escalate to a higher level of support (if they have one), as it is a Netflix issue.

Keep in mind they have to write these apps for different operating systems & hardware, and things like this can happen, how they deal with it is what matters.

If they manage a quick fix, I may go back, but if they drag their arrogant feet, good riddance... Even without Netflix I have more to stream than I can possibly watch.... : )

 

Good luck!

 

0 Kudos
Community Manager
Community Manager

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Thanks for reaching out here. 

With this type of settings change, you might try a channel refresh to see if this clears up the issue. Follow these steps, in order: 

1. Remove the Netflix channel from the Roku home screen by navigating to the channel tile, pressing the * key and choosing 'Remove channel'. 

2. Restart your Roku device from Settings>System>System restart 

3. Add the Netflix channel back once more and sign in again. 

This should help clear up that type of issue. Let us know if you have any other questions, or feel free to follow up with the channel provider directly. 

 

Cheers,

Tanner

Tanner D.
Roku Community Manager

View solution in original post

Highlighted

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Thanks for the fix, Tanner.  That worked.  I had actually tried this on my own last week, but the fix didn't stick.  I think the problem is that I only restarted 1 of my 4 Roku's and my settings somehow got copied from one box to another.  This time, I performed the 3 steps you suggested on all 4 boxes and in parallel, and that appears to have fixed things permanently.  Thanks again!

0 Kudos
Highlighted
Koala
Level 8

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

This worked for me as well.

0 Kudos