Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mooreted
Level 8

Can't Turn Off Netflix Auto Preview

Jump to solution

I have logged into my Netflix account and turned off auto preview. The Netflix app on Roku still plays previews when I browse. I have tried rebooting the Roku. Why doesn't it work?

1 Solution

Accepted Solutions
Highlighted
Community Manager
Community Manager

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Thanks for reaching out here. 

With this type of settings change, you might try a channel refresh to see if this clears up the issue. Follow these steps, in order: 

1. Remove the Netflix channel from the Roku home screen by navigating to the channel tile, pressing the * key and choosing 'Remove channel'. 

2. Restart your Roku device from Settings>System>System restart 

3. Add the Netflix channel back once more and sign in again. 

This should help clear up that type of issue. Let us know if you have any other questions, or feel free to follow up with the channel provider directly. 

 

Cheers,

Tanner

Tanner D.
Roku Community Manager

View solution in original post

22 Replies
Highlighted
Koala
Level 8

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Same problem here. Checked for updates. Rebooted. Still autoplays previews. 

0 Kudos
Highlighted
mooreted
Level 8

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

I just tried singing out and back into Netflix on Roku. It didn’t work. Still auto playing previews. 

0 Kudos
Highlighted
blade_005
Level 13

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

@mooreted wrote:

I just tried singing out and back into Netflix on Roku. It didn’t work. Still auto playing previews. 


I had to do a RESTART of Roku TV before autoplay previews stopped. SETTINGS -- SYSTEM -- POWER - SYSTEM RESTART. Do not have an external Roku device to know if it has RESTART option in Roku OS menu or just do a power cycle of unit.

TCL-TV Roku 55P605 (4K HDR & DV) | VIZIO SB36512‑F6 ATMOS Soundbar
TCL-TV Roku 43S425 (4K HDR) | TCL-TV Roku 32S301 (720p) | Fire TV Stick 4K
0 Kudos
Highlighted
mooreted
Level 8

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Thanks for the suggestion. Tried restarting from the System menu. No change. Tried power-cycling the Roku as well. Guess I'll have to keep wearing out my mute button.

0 Kudos
Highlighted
blade_005
Level 13

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

@mooreted wrote:

Thanks for the suggestion. Tried restarting from the System menu. No change. Tried power-cycling the Roku as well. Guess I'll have to keep wearing out my mute button.


Is this a Roku TV or an external Roku device? I would double check playback settings in web browser to make sure the autoplay previews box is unchecked. If still an issue, I would try the old remove the Netflix app, restart/recycle your Roku device, reinstall the Netflix app and then login.

TCL-TV Roku 55P605 (4K HDR & DV) | VIZIO SB36512‑F6 ATMOS Soundbar
TCL-TV Roku 43S425 (4K HDR) | TCL-TV Roku 32S301 (720p) | Fire TV Stick 4K
0 Kudos
Highlighted
chrisarsen
Level 7

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Same here. I verified that auto previews are disabled on my laptop via running Netflix in my browser. I first tried switching profiles and then switching back and the previews were still auto-playing. Then I restarted Roku and the previews were still auto-playing. Then I uninstalled Netflix app from Roku, restarted Roku, reinstalled Netflix app and re-signed in. The previews are still auto-playing. Ugh!

Roku Streaming Stick + (3810, 3811 series)  

0 Kudos
Highlighted

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Same problem here on all 4 Roku's ... both Roku OS and Netflix app are up to date and Netflix account settings are correct.  Tried restarting the Roku as well, but auto-play is still there.  I changed my Netflix settings as soon as they announced the change 2 days ago and would really like to get rid of the ultra-annoying auto previews.

0 Kudos
Highlighted
mooreted
Level 8

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

Well, crud. I guess there is no fix at this time. Maybe some future update will fix it.

Thanks everyone. 

0 Kudos
Highlighted
boshk
Level 7

Re: Can't Turn Off Netflix Auto Preview

Jump to solution

i have a roku premiere. i turned off previews and restarted netflix, but it didnt take. then i restarted my roku and it now works. i used the remote shortcut to reboot, i dont know if that works any different than cycling power or rebooting through the menu. and the previews stopped.

i did not try re installing netflix or signing out and in. rebooting worked on the first try.

0 Kudos