Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 12

Re: CBS All Access audio


@andyross wrote:
I figured out that if you hit the * key while playing, you can change the audio track to DD+.

I'm resurrecting this older thread because CBS All-Access has a current one-month-free-trial going on during this coronavirus period (3/26/20 as I write this), and the first season of Picard is wrapping up this week. In other words, you can watch/binge through the entire season of Picard and whatever else for 30 days right now and cancel if you like.

OK, here's the deal with CBS All-Access, at least on the Roku set top boxes: The audio defaults to STEREO in the app. I watched an episode and a half of Picard and it was really hard to understand the dialogue with the stereo mix. I had even changed my AVR to Dolby ProLogic (Movie) to try and get some kind of separation, but it didn't help much. Very disappointing. 

Then I found this older Roku forum thread where @andyross figured out that he could get DD+ by tapping the asterisk key on the Roku remote (this might not work for the Roku TVs...just the set top boxes). In the audio track section, it probably defaults to English*, but you can use the right arrow key on the remote to cycle through the other options. "DD+" is an option that will provide Dolby Digital Plus audio output.

(Note: for those with older AVRs that can't decode Dolby Digital Plus, CBS All-Access also has an option to output the audio on the Roku boxes in standard/older Dolby Digital - nice touch. Again, just use the arrow key on the Audio Track section after tapping the asterisk key while playing an episode and select Dolby vs. DD+.)

It's an odd setup for a Roku app to have the audio options like this that don't default to the highest format one's system can handle, but at least it's there now. 

(Note 2: There's a Facebook post from CBS All-Access featuring Patrick Stewart saying to use the promo code "GIFT" for the free trial. When you go to CBS All-Access online, the checkout automatically defaults to - and enters/populates -  the promo code "all". Did for me, anyway.  This promo code works for both the limited ads AND the no ads version of CBS All-Access, so if you plan on canceling before the trial ends, by all means choose the NO ADS free trial!) 

Highlighted
Level 12

Re: CBS All Access audio

I'm resurrecting this older thread because CBS All-Access has a current one-month-free-trial going on during this coronavirus period (3/26/20 as I write this), and the first season of Picard is wrapping up this week. In other words, you can watch/binge through the entire season of Picard and whatever else for 30 days right now and cancel if you like.

OK, here's the deal with CBS All-Access, at least on the Roku set top boxes: The audio defaults to STEREO in the app. I watched an episode and a half of Picard and it was really hard to understand the dialogue with the stereo mix. I had even changed my AVR to Dolby ProLogic (Movie) to try and get some kind of separation, but it didn't help much. Very disappointing. 

Then I found this older Roku forum thread where @andyross figured out that he could get DD+ by tapping the asterisk key on the Roku remote (this might not work for the Roku TVs...just the set top boxes). In the audio track section, it probably defaults to English*, but you can use the right arrow key on the remote to cycle through the other options. "DD+" is an option that will provide Dolby Digital Plus audio output.

(Note: for those with older AVRs that can't decode Dolby Digital Plus, CBS All-Access also has an option to output the audio on the Roku boxes in standard/older Dolby Digital - nice touch. Again, just use the arrow key on the Audio Track section after tapping the asterisk key while playing an episode and select Dolby vs. DD+.)

It's an odd setup for a Roku app to have the audio options like this that don't default to the highest format one's system can handle, but at least it's there now. 

(Note 2: There's a Facebook post from CBS All-Access featuring Patrick Stewart saying to use the promo code "GIFT" for the free trial. When you go to CBS All-Access online, the checkout automatically defaults to - and enters/populates -  the promo code "all". Did for me, anyway.  This promo code works for both the limited ads AND the no ads version of CBS All-Access, so if you plan on canceling before the trial ends, by all means choose the NO ADS free trial!) 

0 Kudos
Highlighted
Level 7

Re: CBS All Access audio

I am having the same issue. The sound reverts to *English from DD+ for each episode (at least Picard and Discovery). I Noted that some shows did not support DD+.

Is there a way to make it always default to DD+?

0 Kudos
Highlighted
Level 12

Re: CBS All Access audio


@Moford wrote:

I am having the same issue. The sound reverts to *English from DD+ for each episode (at least Picard and Discovery). I Noted that some shows did not support DD+.

Is there a way to make it always default to DD+?


If there is, I haven't found it yet. It's a very poor implementation of the app. I've never seen another app where you have to cycle through its Roku audio settings to get surround sound. And then it reverts back to stereo (*English) after each episode, as you and I both know. Maybe someone else has found the magic fix, but I'm going to bet that the app needs somewhat of a rewrite to get that working right.

0 Kudos
Highlighted
Level 7

Re: CBS All Access audio

Thank you a thousand times over for sharing this. I even upgraded my soundbar system in hopes of improving the sound on CBS AllAccess to no avail.

It is unfortunate that it has to be reset for each episode. However, now that I know the remedy, it is a small step to remember.

0 Kudos
Highlighted
Level 8

Re: CBS All Access audio

Is it a Roku issue or CBS?

 

Might be an excuse to use for a change in the 'device'. I recently purchased the 2019 Ultra and also use the older Ultra that does S/PDIF and that's the device I noticed 3AM today doing just PCM. Later 7AM tried a different display and the 2019 Ultra doing the same thing.

0 Kudos
Highlighted
Level 7

Re: CBS All Access audio

The problem seems to be with the CBS app. I had the same problem on an older Roku as well as a 2019 Roku TV. I have used two soundbar systems, Polk Audio and Yamaha with the same results.

Following the directions in earlier posts, the problem was fixed, although it does have to be reset with each episode, show, or movie.

0 Kudos
Highlighted
Level 7

Re: CBS All Access audio

The issue is with the CBS All Access App. Happy with this thread so that I can individually work the problem with my Roku devices. But still have the problem with Fire TV and Amazon Fire Cube due to CBS All Access. Moreover, I don't believe Star Trek Discovery was even originally recorded in the higher Dolby  sound formats. Season 2 has the better sound. But anyways, its the streamer app. In fact, many of the streamer apps are equally weak in sending sound. Only Vudu app does a good job with streaming UHD content with Atmos or DD+ and Dolby Digital Plus 5.1. And my Movies Anywhere app does Dolby Digital Plus 5.1, but no ATMOS. And even Disney+ doesn't offer ATMOS sound quality on its streamer unless streaming through a lossless device like the better Roku streamers or an Xbox. But at least Disney+ does do DD+ on the regular. So what I'm saying is, it's a CBS All Access issue and it's not just limited to that streamer.

0 Kudos
Highlighted
Level 9

Re: CBS All Access audio

Thank you, I didn't realize you can scroll through the english menu to DD+.  Now Star Trek Discovery is 7.1 instead of 2.1.  and the center channel is better matched to the dialogue than the Left/Right channels were in the "English" format.

0 Kudos