Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Search instead for 
Did you mean: 

BBC America not launching

Is anybody else having issues with BBC America?  When I select it I get the splash screen, then it says "Loading" and then I just get dropped back to the menu.  I noticed this first on my new Ultra but just confirmed the same behavior on my 3 that's in the bedroom.  I've tried the usual steps suggested here (Remove/Reboot/Reinstall and Remove/Unplug for 30 seconds/Reinstall) but still get the same thing.  BBC America is listed as Version 2.0 Build 12.  I did a forced check for updates on the Ultra and there were none.  I don't recall exactly when it last worked, it's been at least 6 to 8 weeks back when I still had a 3 in my primary setup.
SoundBridge M500 (retired), PhotoBridge HD1000 rev. B (retired)
Roku 2 XS (retired), Roku XD (retired)
Roku 3 x2, Roku 2, Roku Ultra
0 Kudos
5 Replies

Re: BBC America not launching - SUPPORT REQUEST

I have contacted BBC America but have not heard anything back after several days.

As mentioned below the BBC America Channel does not launch on either of the Rokus I have at home; an Ultra (4660X) and a 3 (4200X). 
I get the splash screen, then "loading" then back to the main Roku menu.  Every time.
The Channel version on both boxes is 2.0 Build 12.
The Ultra is running 8.1.0 build 4145-46, the 3 is 8.1.0 build 4145-04
Both devices are wired ethernet and I have Verizon Fios gigabit fiber service
The 3 is connected via HDMI to a Samsung LCD (@ 1080P) the Ultra is connected to an Onkyo Receiver then to a Panasonic plasma (also 1080P)
The Channel has worked many times in the past, I don't recall exactly how long since we tried last (a couple of months?)  I authenticate to it via my FIOS TV account.  I can stream from their website.

Any help would be appreciated.
SoundBridge M500 (retired), PhotoBridge HD1000 rev. B (retired)
Roku 2 XS (retired), Roku XD (retired)
Roku 3 x2, Roku 2, Roku Ultra
0 Kudos
blade_005
Level 11

Re: BBC America not launching

Checked on two (2) TCL Roku TV's and BBC AMERICA is working.
TCL-TV Roku 55P605 (4K HDR & DV) | VIZIO SB36512‑F6 Soundbar
TCL-TV Roku 43S425 (4K HDR) | TCL-TV Roku 32S301 (720p)
0 Kudos

Re: BBC America not launching

"blade_005" wrote:
Checked on two (2) TCL Roku TV's and BBC AMERICA is working.

Bad news for me, but good to know.
SoundBridge M500 (retired), PhotoBridge HD1000 rev. B (retired)
Roku 2 XS (retired), Roku XD (retired)
Roku 3 x2, Roku 2, Roku Ultra
0 Kudos

Re: BBC America not launching

I am still unable to launch BBC America.  One thing I noticed is that every time I install the channel, on either of my Rokus, I get version 2.0 build 12.  However, when I look in the Channel Store it shows as being version 2.5.  Could this be causing my issue?  Why wouldn't I be getting the latest version of the channel when I install it?

I am rebooting in between de-install and re-install.
SoundBridge M500 (retired), PhotoBridge HD1000 rev. B (retired)
Roku 2 XS (retired), Roku XD (retired)
Roku 3 x2, Roku 2, Roku Ultra
0 Kudos

Re: BBC America not launching

Looks like the 9.0 upgrade solved this issue for me.  I know you were all anxiously awaiting word on this.
SoundBridge M500 (retired), PhotoBridge HD1000 rev. B (retired)
Roku 2 XS (retired), Roku XD (retired)
Roku 3 x2, Roku 2, Roku Ultra
0 Kudos