Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Lyndee
Level 9

Re: Are you being returned to Home screen after selecting a channel?

Thanks for the tips much appreciated however I tried all the fixes nothing is working could it be a glitch or system errors it is not one or 2 person only it is a whole community. But the weird is that ROKU 2 UPOADS THE CHANNEL BUT ROKU EXPRESS DOESN'T !Any ideas ?

0 Kudos
cnote1114
Level 8

Re: Are you being returned to Home screen after selecting a channel?

So I'm having the same issue but it's with the YouTube app, not YouTube TV. Click on the app, it flashes the YouTube like it's loading but then instead if going to the all, it returns to the home screen. I have an older TCL Roku tv. Also I noticed if left in the home too long, it goes to start the YouTube app randomly but then returns to the home screen. Just started this nonsense a few hours ago (about 1030om) HELP😩

Lyndee
Level 9

Re: Are you being returned to Home screen after selecting a channel?

Yes am having the issue with YouTube app as well😩 I just read a post from an expert streamer she said it could be a YouTube app update version issue and Google will be the one to determine whether the app updates will be pushed to all devices . But so far no definite answer nor solution from Roku staff

cnote1114
Level 8

Re: Are you being returned to Home screen after selecting a channel?

It's odd though because it still works on the Roku premiere box I have downstairs, but the Roku TV I have here in my room, well, a bunch of nonsense is what it's doing..... Thanks for any help and good luck to you.....I'll post if I get or hear about a fix for it....👍

Lyndee
Level 9

Re: Are you being returned to Home screen after selecting a channel?

Yes I just plugged in the Roku 2 and it uploaded BUT it DOESN'T LOAD ON ANY OF ROKU EXPRESS🤦‍♀️ So what a waste of money if we need to buy new roku devices ☹

0 Kudos
Steve74gd
Level 7

Re: Are you being returned to Home screen after selecting a channel?

5317X

2N0086842943

7D6798842943

YouTube Tv, YouTube

43-379-144

0 Kudos
katty08
Level 7

Re: Are you being returned to Home screen after selecting a channel?

I’m having trouble with YouTube playing, every time I try to launch it, it reverts back to the homepage. The channel was working perfectly yesterday, now out of a sudden it stopped working.

Has anyone found a way to get the channels working again or does it last a while (couple days) before they start launching correctly?  

Hateful_Kate_87
Level 7

Re: Are you being returned to Home screen after selecting a channel?

Are there actual people who work for Roku? Can 1 of you fix this s**t? Started after a blown breaker yesterday around 4pm. Was in the YouTube App when everything shut down. Have been unable to access YouTube since 4pm on 9/20, I click on the app and it shows the loading thing then it goes right back to home screen. Ive done every mentioned work around except factory resetting my tv. I guess thats the only thing left to do though so I'll give it a shot. Wish me luck.

 

Model-    Hitachi Roku Tv- 5510X

Serial-    2NOOOK118996 (994690118996)

Software Version- 10.0.0 Build 4209-32

Issue ID-     96-379-304

Joseph3
Level 9

Re: Are you being returned to Home screen after selecting a channel?

Seems like every ROKU TV owner is experiencing the same problem.  I too have exhausted my efforts to solve this problem  while ROKU HAS DONE NOTHING  to fix this bug.  I fear they will have to RECALL ALL ROKU  TV products as being defective...or re-program all of their software products which are loaded in our TVs. Otherwise I fear a CLASS-ACTION (word being censored) will be popping up soon.

Jsmith99
Level 7

Re: Are you being returned to Home screen after selecting a channel?

Yes,  with the YouTube channel only.  All other channels work fine.  I removed the app,  I then rebooted and reinstalled the channel.  It does the same thing.  YouTube channel is the only one I've ever had an issue with.  I have two Roku hd devices and get the same thing on both.  No errors or messages, it just goes back to home.