Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MonicaV
Level 7

Apps crashing on all Roku devices

I noticed a couple weeks ago that when I tried to open my Bravo app, it would run for a few seconds then crash. I thought it was just that particular app.

Then I noticed it was happening on almost all my apps, except Netflix, Hulu and Disney +.

THEN I noticed it was not only happening on the Roku in my living room, but on all my Roku devices.

I have restarted my Roku, cleared the cache, did a factory restart, tried deleting the apps and then reinstalling them.

Nothing works. They all start to open, run for a second or two, then crash and return to the Roku Home Screen.

PLEASE HELP! I feel like I have researched ans tried everything. 

0 Kudos
1 REPLY 1\
StreamerUser
Level 20

Re: Apps crashing on all Roku devices

Don't know how many Roku devices there are, or what their model #s or firmware versions are (important info you didnt provide).   Settings/System/About

You say what apps it isnt happening on, but you dont say what apps it is happening on (aside from Bravo).

You mention some steps you took, but you only seem to have done them with one of your Rokus ("my Roku")

When reinstalling apps, the correct order is:

1) Remove app

2) Restart Roku (Settings/System/System restart)  <- MUST DO THIS HERE

3) Add app again.

If you dont follow that procedure, settings/cached data for the app remain.

Otherwise, try these steps:

1) Change your Theme to the Roku Default (Settings/Theme/Restore default theme) - try again

2) Change your Screensaver to a Roku clock (Settings/Theme/Screensavers) - try again

3) Check for updates (Settings/System/System updates/Check now) - try again

4) Network connection reset (Settings/System/Advanced system settings) - try again

5) Restart your modem/router/gateway/AP - try again

0 Kudos