Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 9

Amazon Will not work. 9.3 OS Express device

Jump to solution

As of this afternoon:  Selected a movie on Roku channel, it played 4 ads, then kicked out to Resume/PlayFromBeginning/etc options, I chose Resume, got another 4 ads, repeated a third time.  Selected another movie, seemed to be fine.  Went to Prime, made selection, got the main prime video logo--and nothing else except the prime logo flashing/stuttering on/off with blank screen.  Unplugged everything, rebooted--same thing all the way through testing.  Advice, please?  All thanks!

2 Solutions

Accepted Solutions
Highlighted

Re: Another Roku "update"?

Jump to solution

Hi everyone.  I have solved this issue but you are not going to like it.  I did an online chat with amazon.com and they walked me through the solution.  It worked on both of my Roku Express+ devices.

1)  You need to perform a factory reset and reconnect your Roku to the internet and your Roku account.  Do not attempt to login or subscribe to anything yet.  Like I said, you are not going to like this.

2) If necessary, add Prime Video channel.  Login as prompted.  That channel should now work.  You will notice they now have profiles to set up if you have not yet done so.

3) Login to whatever other channels you have been using.

It is important that you setup Prime Video channel FIRST (at least for me it was).  If you do not, you may need to start over with yet another factory reset.

I hope this works for you.  Please feel free to share as needed.

Have a great day.  Smiley Happy

Mike P.

View solution in original post

Highlighted
Roku Employee
Roku Employee

Re: Amazon Prime stopped working yesterday, 10/2 on my Roku Express+. ???

Jump to solution

Hi everyone,

Thanks for your patience regarding this issue.

We believe this issue is resolved now. We would recommend trying to remove the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more. 

Please keep us posted what you find out.

Thanks,
Danny

Danny R.
Roku Forum Moderator

View solution in original post

169 Replies
Highlighted
Level 7

Re: Can't load Prime...bounces back to main menu

Jump to solution

I use a Roku Express 3310x with composite connection (not HDMI). I just tried to log into the Amazon Prime Videos channel. The screen flashed for a bit like it was logging in, flashed again and then gets stuck without ever bringing up the titles or even kicking me back to the home screen (a problem I have read about on this forum). I have tried uninstalling the channel, shutting off the device and then reinstalling the channel, but I have the same issue. I took the device over to my other TV which uses the HDMI connection and everything worked fine except I had to re-register. I reconnected it to my composite-only TV and the same problem persists. Seems like a resolution problem. Does anyone have any suggestions? Thank you, kindly!

Highlighted
Level 8

Re: Another Roku "update"?

Jump to solution

Prime Video doing the same on my end. Other channels seem to work okay. 

roku express+ Running 9.3. My ultra seems unaffected. 

Highlighted

Re: Another Roku "update"?

Jump to solution

Yep, I have the same issue.  Still not resolved as of 10/3/2020.  I have the issue on both my Express+ devices.  Will someone from Roku reply ????

Highlighted
Level 7

Amazon Prime stopped working yesterday, 10/2 on my Roku Express+. ???

Jump to solution

Yesterday, all of a sudden, I can't get Amazon Prime on my Roku Express+.  All that shows up is a blue screen with "Prime Video" on it and it either stops there or just goes blank.  

Someone at Roku's technical support has to get onto this, please.  

Highlighted
Level 7

Re: Amazon Prime stopped working yesterday, 10/2 on my Roku Express+. ???

Jump to solution

We have the same issue, started same day with #Roku Express+. We cleared cache, removed #Prime Video app, turned off power to Roku for 2 minutes, added app back and it still will not connect to Prime Video. All other channels working fine. Please offer additional suggestions. Thank yo

0 Kudos
Highlighted
Level 7

Re: Amazon Prime stopped working yesterday, 10/2 on my Roku Express+. ???

Jump to solution

Same issue. Prime Video on Roku stopped working. Uninstalled channel and added back. Restarted Roku device. Still fails.

0 Kudos
Highlighted
Level 8

Re: Amazon Prime stopped working yesterday, 10/2 on my Roku Express+. ???

Jump to solution

I am having the exact same problem. Started yesterday also. I just get the blue screen with "Prime Video" and then it goes black. I tried all the problem solving steps and that did not fix it.

0 Kudos
Highlighted
Level 9

Re: Amazon Prime stopped working yesterday, 10/2 on my Roku Express+. ???

Jump to solution

Yup, we are, too. Same old problem. Seems like every few months, Prime Video stops working when using Roku's Express+. When I click on Prime Video, the logo comes up, then the screen goes black. That's it. Nothing happens. I've restarted Roku, and even did a hard reboot. This is a recurring problem, so I'm not even going to bother trying all the other "fixes" that Roku recommends. And, the problem isn't Amazon, as some Roku support person claimed. I've gone through this too many times. It requires support from Roku, and until then, it won't get fixed. Hello, Roku? Are you there?

Highlighted
Level 7

Amazon Prime Video and Audio Not Working

Jump to solution

Amazon Prime Video and Audio stopped working 10/2/2020 - tries to load but then goes to the blue screen and does nothing. Checked for new updates, restarted ROKU, even tried to go back to previous updated version with no luck.

0 Kudos