Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Adding Chanels to my online account but not showing up on my TV

Jump to solution

Like the title, I've added channels on the Roku website but they're not uploading to my TV. Am I doing something wrong?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Level 18

Re: Adding Chanels to my online account but not showing up on my TV

Jump to solution

Channels added to your account via the website will be added the next time your Roku auto-updates.  You can cause it to update manually via Settings > System > System update.

Note that some channels rely on the enhanced capabilities of newer Roku models and may not install on older discontinued models that are no longer receiving software updates from Roku.

  • Roku Streaming Stick +, 3810X, Ser YH0059427035, wifi - Samsung UN55ES6100
  • Roku Streaming Stick, 3600X, Ser 5S56D8240827, wifi - JVC EM37T
  • TCL Roku TV 43S425/C107X, Ser X000001R60KV, wifi

View solution in original post

1 Reply
Highlighted
Level 18

Re: Adding Chanels to my online account but not showing up on my TV

Jump to solution

Channels added to your account via the website will be added the next time your Roku auto-updates.  You can cause it to update manually via Settings > System > System update.

Note that some channels rely on the enhanced capabilities of newer Roku models and may not install on older discontinued models that are no longer receiving software updates from Roku.

  • Roku Streaming Stick +, 3810X, Ser YH0059427035, wifi - Samsung UN55ES6100
  • Roku Streaming Stick, 3600X, Ser 5S56D8240827, wifi - JVC EM37T
  • TCL Roku TV 43S425/C107X, Ser X000001R60KV, wifi

View solution in original post